WordPress Automatic Upgrade 失敗

之前看到 WP 放出新版,都會用 automatic upgrade 這個很貼心無腦的功能來升級,但是前一陣子居然失效了,先是出現要求我輸入 FTP/SFTP 連線的授權,但輸入了卻又無法進行 upgrade:

blog error message

後來發現原來是 directory 權限問題,只要把 WP 安裝目錄改成讓 apache 可以讀寫即可: (以 Ubuntu 為例)

sudo chown www-data:www-data wp_directory

筆記一下。